Hello Guest

Author Topic: Problem with install  (Read 3456 times)

0 Members and 1 Guest are viewing this topic.

Offline ricardo

  • Full Member
  • ***
  • Posts: 25
  • Karma: 0
    • View Profile
Problem with install
« on: November 06, 2008, 02:01:34 AM »
I have a problem with the installation of babel svn in debian etch 4.0

When I execute "autogen.sh" displays this error:

./configure: line 20992: syntax error near unexpected token `BABEL,'
./configure: line 20992: `PKG_CHECK_MODULES(BABEL,'

I don't know what to do.

Offline Manuel Arostegui

  • Global Moderator
  • Expert member
  • *****
  • Posts: 853
  • Karma: 50
    • View Profile
Problem with install
« Reply #1 on: November 06, 2008, 05:34:38 AM »
What version are you trying to install? trunk/ from the SVN?

Offline ricardo

  • Full Member
  • ***
  • Posts: 25
  • Karma: 0
    • View Profile
Problem with install
« Reply #2 on: November 06, 2008, 06:13:10 PM »
Yes. is the trunk version , I updated to day with this command:

svn co https://babel.svn.sourceforge.net/svnroot/babel/trunk babel

then autogen.sh, and the same error:
checking for ANSI C header files... (cached) yes
./configure: line 20992: syntax error near unexpected token `BABEL,'
./configure: line 20992: `PKG_CHECK_MODULES(BABEL,'

Offline esteban

  • Jr. Member
  • **
  • Posts: 15
  • Karma: 0
    • View Profile
Problem with install
« Reply #3 on: November 06, 2008, 06:23:37 PM »
Hi,

I believe you're missing pkg-config tool in your system.

To install it on Debian/Ubuntu:

sudo apt-get install pkg-config

Greetings

Offline ricardo

  • Full Member
  • ***
  • Posts: 25
  • Karma: 0
    • View Profile
Problem with install
« Reply #4 on: November 06, 2008, 07:11:21 PM »
Ouch! Homer Simpson dixit :)

Now, all works fine

Offline ricardo

  • Full Member
  • ***
  • Posts: 25
  • Karma: 0
    • View Profile
Problem with install
« Reply #5 on: November 06, 2008, 07:48:34 PM »
In the spanish documentation [ http://www.openideas.info/wiki/index.php?title=Babel:Documentation_es:Installation ] is missing a line in "Prerequisitos", in the software needed to comp├Čle Babel is missing "libglib2.0-dev"

Offline Manuel Arostegui

  • Global Moderator
  • Expert member
  • *****
  • Posts: 853
  • Karma: 50
    • View Profile
Problem with install
« Reply #6 on: November 06, 2008, 07:55:31 PM »
True!
I just added it!

Thank you!

Offline koucliac

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: Problem with install
« Reply #7 on: October 05, 2010, 05:37:50 AM »
This happens in some cases, resume websites have useful information on the subject.

Offline Sancho Lerena

  • Administrator
  • Expert member
  • *****
  • Posts: 1283
  • Karma: 28
  • I can see everything... with my glasses :-)
    • View Profile
    • Pandora FMS
Re: Problem with install
« Reply #8 on: October 16, 2010, 06:19:05 AM »
Next version (already present in SVN) has the server implemented in perl, avoiding problems on compiling. You can try it. In next months we will release Babel 3.0 with new console, new agents and new server.
-- See you in the other screen.