Hello Guest

Author Topic: Pandora Modules getting Grey easily  (Read 945 times)

0 Members and 1 Guest are viewing this topic.

Offline nydiow

  • Full Member
  • ***
  • Posts: 36
  • Karma: 0
    • View Profile
Pandora Modules getting Grey easily
« on: June 07, 2011, 06:04:31 AM »
Hello guys! Im here to ask for some help again!

Since Pandora 3.2.1 was launched we are using this Monitoring System, the problem is we have many modules created by plugin server and i think the server is getting heavy. Id like to know how can i optimize my Pandora Server (Data, Networ, Plugin and Prediction). I've heard someone saying that is possible to improve MySQL as well (there are two ways, one with one file to each table and another for write cache activated) but i dont know what a have to do.

The reason is, my agents are Greey very often (the Last contact is always red, the agents are often out of their pool time)

Can you guys help me out? Im running Debian!

Thanks!

Regards,

Diego Ramos

Offline nydiow

  • Full Member
  • ***
  • Posts: 36
  • Karma: 0
    • View Profile
Re: Pandora Modules getting Grey easily
« Reply #1 on: June 08, 2011, 07:23:12 AM »
Oh, here is my my.cnf (running on debian quadcore, 4GB RAM)

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port            = 3306
socket          = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket          = /var/run/mysqld/mysqld.sock
nice            = 0

[mysqld]
#
# * Basic Settings
#
user            = mysql
pid-file        = /var/run/mysqld/mysqld.pid
socket          = /var/run/mysqld/mysqld.sock
port            = 3306
basedir         = /usr
datadir         = /database/mysql
tmpdir          = /tmp
language        = /usr/share/mysql/english
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
#bind-address           = 127.0.0.1
#
# * Fine Tuning
#
key_buffer              = 128M
max_allowed_packet      = 16M
thread_stack            = 128K
thread_cache_size       = 512
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover          = BACKUP
max_connections        = 500
table_cache            = 2048
thread_concurrency     = 5
#
# * Query Cache Configuration
#
query_cache_limit       = 2M
query_cache_size        = 64M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log            = /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
#log_slow_queries       = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id              = 1
#log_bin                        = /var/log/mysql/mysql-bin.log
expire_logs_days        = 10
max_binlog_size         = 100M
#binlog_do_db           = include_database_name
#binlog_ignore_db       = include_database_name
#
# * BerkeleyDB
#
# Using BerkeleyDB is now discouraged as its support will cease in 5.1.12.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
# You might want to disable InnoDB to shrink the mysqld process by circa 100MB.
#skip-innodb
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem
[mysqldump]
quick
quote-names
max_allowed_packet      = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer              = 32M

#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the NDB Data Nodes (ndbd processes)
# not from the NDB Management Nodes (ndb_mgmd processes).
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1


#
# * IMPORTANT: Additional settings that can override those from this file!
#   The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/



Offline daniels

  • Smart member
  • *****
  • Posts: 206
  • Karma: 19
    • View Profile
Re: Pandora Modules getting Grey easily
« Reply #2 on: June 14, 2011, 12:22:16 PM »
Hi Diego.

  Can you do the remote checks less often? If you increase the time between the checks, your server will become more idle.

  I do agent checks in all my monitored servers and use the plugin-remote check only for specific tasks.

   Another tip is to set up your database server in another machine. It worked well for me.

  I hope this helps.

Regards.

Offline nydiow

  • Full Member
  • ***
  • Posts: 36
  • Karma: 0
    • View Profile
Re: Pandora Modules getting Grey easily
« Reply #3 on: June 15, 2011, 10:21:33 AM »
Hey daniels, thanks for answering!

The problem is my Network Server and Plugins are working fine! The problems is the Data Server (The XML from the Agents)

Check this out:

pandora-server               Data server (Data)                          5:18 minutes / 109          257 of 257           5:18 minutes / 109          10 : 0                 4 seconds
pandora-server               Network server (Network)        4 seconds / 19                  1121 of 1121      4 seconds /        19           8 : 0                 4 seconds
pandora-server               Plug-in server (Plugin)                  13 seconds / 55                605 of 605           13 seconds / 55                1 : 27                 4 seconds

Some agents are taking more than an hour to refresh!

Im setting my DataBase Server in another machine for improving performance. As i said my big problem is the Data Server.

Offline daniels

  • Smart member
  • *****
  • Posts: 206
  • Karma: 19
    • View Profile
Re: Pandora Modules getting Grey easily
« Reply #4 on: June 30, 2011, 06:55:52 AM »
Hi nydow.

   If the problem is the performance of the database, one alternative is to use mysql with innodb. In my case, I use one file per table (it's working fine to me). Remember: If you are going to change the Storage Engine of your MySQL from MyISAM to InnoDB make a FULL BACUKP before ;-) It's better to be safe than sorry.


The database server is a quad-core Xeon 3.2GHz with 4GB of RAM:

The specific confs that I use in my.cnf to do the job are:


------------------------------------------------------------
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
innodb_buffer_pool_size=2G

# Allow packets up to 1M
max_allowed_packet=4M
# Allow small words in full-text indexes
ft_min_word_len=2
# Configure Inoddb file per table
innodb_file_per_table
# Escreve no disco somente a cada segundo
innodb_flush_log_at_trx_commit=0

------------------------------------------------------------


Another thing: Check if the XML files received by the Pandora Server are being processed correctly. I had some problems with BAD_XML files that resulted in gray modules.

Regards.

Offline nydiow

  • Full Member
  • ***
  • Posts: 36
  • Karma: 0
    • View Profile
Re: Pandora Modules getting Grey easily
« Reply #5 on: July 05, 2011, 06:28:00 AM »
Hey daniels, im setting a mysql with innodb, i just build a new server and restore the database and changed the engines to innodb using the command below:

mk-find  --engine MyISAM --exec "ALTER TABLE %D.%N ENGINE=INNODB" --print (Need Maatkit)

This way i was able to change all my Pandora Tables to INNODB at once.

But your my.cng didnt work for me, i had to put those lines in place of skip-innodb:

innodb
innodb_file_per_table = 1
innodb_flush_log_at_trx_commit = 2

Is that correct?

Offline daniels

  • Smart member
  • *****
  • Posts: 206
  • Karma: 19
    • View Profile
Re: Pandora Modules getting Grey easily
« Reply #6 on: July 07, 2011, 03:49:16 AM »
Hi Diego.

  I'm not a mysql guru... I start to use this settings some years ago when I had the first problems with performance of the MySql database.. I did some research and test that time, and those settings worked fine to me.

  I advice you to take a look at:
http://openideas.info/wiki/index.php?title=Pandora_3.0:Documentation_en:Anexo_AjusteMySQL

  I hope this helps.

Regards.

Offline nydiow

  • Full Member
  • ***
  • Posts: 36
  • Karma: 0
    • View Profile
Re: Pandora Modules getting Grey easily
« Reply #7 on: July 08, 2011, 09:49:33 AM »
Hi Diego.

  I'm not a mysql guru... I start to use this settings some years ago when I had the first problems with performance of the MySql database.. I did some research and test that time, and those settings worked fine to me.

  I advice you to take a look at:
http://openideas.info/wiki/index.php?title=Pandora_3.0:Documentation_en:Anexo_AjusteMySQL

  I hope this helps.

Regards.

Bloody hell ive never seen this doc before, looks good, ill take a look! thanks!