Hello Guest

Recent Posts

Pages: 1 2 [3] 4 5 ... 10
21
Español / Spanish forum / Re: Consulta SQL y modulo no inicializado
« Last post by gairhald on April 20, 2017, 04:49:44 AM »
Vaya, ahora el problema que tengo es que cuando lo ejecuto con el servicio de PANDORA, no tiene permisos para escribir datos, por lo que no me sirve...es posible poder ejecutar la llamada a powershell como adminsitrador desde el pandora.conf¿

Code: [Select]
module_exec run as powershell -File sqlcmd.ps1
Rollo algo asÍ? merci
22
Buenos días y gracias de antemano por el apoyo prestado.

Siguiendo la guía de actualización de PFMS v6 a v7NG  después de actualizar la consola ejecuto el comando para actualizar la BD

[root@localhost] cat /var/www/html/pandora_console/extras/pandoradb_migrate_6.0_to_7.0.mysql.sql | mysql -uroot -ppandora -D pandora

una vez acabada la ejecución aparece el mensaje:

ERROR 1060(42S21) at line 1256: Duplicate column name 'dynamic_next'

continúo y concluyo con la actualización del server. A continuación levanto los servers de pandora y de tentacle y me logo en la consola web. Accedo a la pestaña "Estado BD" para ejecutar un testeo y el resultado final es

ERROR Creación de la BD testeada sin éxito.

¿Ha fallado la migración de la BD? ¿Cómo podría depurar el problema?

De nuevo, gracias por anticipado.
23
Help for new users in Pandora FMS / Re: Installing Pandora FMS Agent on Mac OS X
« Last post by antonio.s on April 19, 2017, 04:17:51 AM »
Hello castcord,

I don't know why you need to restart the agent service when you reboot you computer if when booting it is already running, first time I see this. A quick solution that should work is to execute a pandora_agent_daemon restart on system startup. I don't know where this script is located on mac, but on a CentOS type, something like adding the restart command at the end of the /etc/rc.local file should work.

Kind regards,
Antonio.
24
Español / Spanish forum / Re: Problemas al instalar agente en modo Proxy
« Last post by antonio.s on April 19, 2017, 04:13:42 AM »
Hola mario741,

Perfecto, efectivamente el modo proxy utiliza por debajo tentacle para reenviar la información, por lo que es necesario permitir el tráfico 41121.

Un saludo,
Antonio.
25
Help for new users in Pandora FMS / Re: Installing Pandora FMS Agent on Mac OS X
« Last post by castcord on April 19, 2017, 03:50:25 AM »
It was a wrong module configuration, now it's working.

This is a module example that is currently working in my Mac OSX:
Code: [Select]
module_begin
module_name %CPU service_name
module_type generic_data_string
module_exec pgrep -f service_name | xargs ps -o %cpu | grep -v %CPU | head -n 1
module_description %CPU service_name
module_end

The problem is that if I reboot Mac OSX, this service monitoring is not refreshed on Pandora server, even if Pandora Agent is running and service "service_name" is also up.
I have to restart Pandora Agent Daemon every time, to get this module updated on Pandora server:
Code: [Select]
sudo /path/to/pandora/daemon/pandora_agent_daemon restart

Coud you help me on this?

Thanks you so much,

Aaron
26
Español / Spanish forum / Re: Problemas al instalar agente en modo Proxy
« Last post by mario741 on April 19, 2017, 03:45:02 AM »
Solucionado, solo era necesario incluir una nueva regla en el corta fuegos para aceptar las comunicaciones por el puerto 41121 o bien crear una nueva entrada en iptables con la IP o rango de IPs que no son accesibles por el servidor.
27
Español / Spanish forum / Re: Consulta SQL y modulo no inicializado
« Last post by antonio.s on April 19, 2017, 02:59:30 AM »
Uf! Sí has tenido que darle un par de vueltas al final, pero bueno lo importante es que funcione :)

Nada! Me alegro de que hayas logrado solucionarlo. Como consejo para futuras te digo lo mismo, siempre ir reduciendo hasta "la mínima unidad" suele ser buena idea, y se van descartando posibles puntos problemáticos.

Un saludo,
Antonio.
28
Español / Spanish forum / Re: Consulta SQL y modulo no inicializado
« Last post by gairhald on April 19, 2017, 02:54:16 AM »
YA ESTA!!

El problema era como había comentado antes, problema de tipo de datos, al ahcer la consulta, me estaba dando un STRING y no podía convertirlo de array a un int  en powershell, así a saco.

Así que he tenido que guardar la consulta en un TXT y recogerlo de nuevo en otro array que me lo separaba por saltos de linea y luego unicamente he de mostrar el valor del array que me interesa, que ya lo detecta como un integer.

Un  poco rebuscado, pero bueno, funciona que es lo que necesitaba, merci por la ayuda Antonio!

Code: [Select]
$query = SQLCMD.EXE -d xxxxxx -U xxxxx -P xxxxx -i "C:\Scripts\CSA_QUI.sql" | Out-File -FilePath C:\Scripts\sqlquery.txt -Append

$fileContents = Get-Content "C:\Scripts\sqlquery.txt"
$ficheros = $fileContents -split "`r`n"
$ficheros[2]
29
Español / Spanish forum / Re: Consulta SQL y modulo no inicializado
« Last post by gairhald on April 19, 2017, 02:23:05 AM »
Buenas Antonio

he creado otro script mas basico que recoja la hora

Code: [Select]
$date=get-date
$date.hour

si lo ejecuto, tanto en powershell como en el CMD me devuelve el valor de la hora, solo las HORAS, es decir ahora mismo me da 10.
Si debugo, veo en el XML que si, si recoge ese valor 10

Code: [Select]
<module>
[code]<name><![CDATA[Bustia Palex]]></name>
<type><![CDATA[generic_data]]></type>
<description><![CDATA[Bustia Palex]]></description>
<module_interval><![CDATA[1]]></module_interval>
<module_group>application</module_group>
</module>
<module>
<name><![CDATA[echo]]></name>
<type><![CDATA[generic_data]]></type>
<description><![CDATA[echo]]></description>
<module_interval><![CDATA[1]]></module_interval>
<module_group>application</module_group>
<data><![CDATA[10]]></data>
</module>
</agent_data>

Pero el otro me sigue sin funcionar, no recoge los datos

Creo que es un problema de tipo de datos. Lo que estoy sacando es un string y pandora necesita recoger un intenger,no? Pero me estoy peleando con convertirlo a int y tampoco parece que funcione...voy a ver si lo puedo sacar de otra manera o algo
30
Español / Spanish forum / Re: Consulta SQL y modulo no inicializado
« Last post by antonio.s on April 19, 2017, 12:38:17 AM »
Hola gairhald,

Ahora que me fijo, es posible que necesites poner la ruta completa también al script en la línea module_exec. Algo así:

Code: [Select]
module_exec "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe" -File "C:\Program Files\pandora_agent\util\sqlcmd.ps1"

Y te aconsejo que continues utilizando el modo debug y analizando lo que muestra el XML para poder descubrir cuál es el problema. Si no se resuelve rápidamente poniendo las rutas completas, prueba jugando con el tema de las comillas, o incluso simplificando la ejecución por un script ps1 que simplemente haga un "echo 1", para ver si el problema puede estar en el script (que no devuelva un resultado de ejecución admitido o similar). Así ir reduciendo las pruebas hasta ver dónde está el problema, y luego ponerse a solucionarlo :P

En cuanto al salto de línea, no creo que sea el problema, efectivamente creo que cmd tiene ese comportamiento siempre cuando se ejecutan los scripts llamando a powershell desde cmd.

Un saludo,
Antonio.
Pages: 1 2 [3] 4 5 ... 10