Hello Guest

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - AxL_

Pages: [1]
1
Community support (English) / Can't locate Socket6.pm
« on: January 28, 2013, 02:29:55 AM »
Hello everyone,

I've installed PandoraFMS Open 4.0.2 server and I'm having some troubles making it run.

When I type:
Code: [Select]
/etc/init.d/pandora_server start
I get the following error:

Can't locate Socket6.pm in @INC (@INC contains: /usr/lib/perl5/5.8.8 /usr/lib/perl5 /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.7/x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.6/x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.8.7/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.8.6/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi .) at /usr/lib/perl5/vendor_perl/5.8.8/IO/Socket/INET6.pm line 16.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/IO/Socket/INET6.pm line 16.

But guess what, they are already installed:
Code: [Select]
rpm -qa | grep perl
perl-HTML-Parser-3.55-1.fc6
net-snmp-perl-5.3.1-14.el5
graphviz-perl-2.30.0-1.el5
perl-XML-Parser-2.34-6.1.2.2.1
perl-String-CRC32-1.4-2.fc6
perl-IO-Socket-INET6-2.51-2.fc6
perl-5.8.8-10
perl-URI-1.35-3
perl-XML-Twig-3.26-1.fc6
perl-Compress-Zlib-1.42-1.fc6
perl-libwww-perl-5.805-1.1.1
perl-DBD-MySQL-3.0007-2.el5
perl-NetAddr-IP-4.027-5.el5_6
perl-DBI-1.52-2.el5
perl-Socket6-0.19-3.fc6
perl-HTML-Tagset-3.10-2.1.1
perl-XML-Simple-2.14-4.fc6

These two modules are installed in different folders... maybe that's the problem? I don't know.
Code: [Select]
locate Socket6.pm
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/Socket6.pm

Code: [Select]
locate INET6.pm
/usr/lib/perl5/vendor_perl/5.8.8/IO/Socket/INET6.pm

Any help would be awesome!
Thanks! :)

Pages: [1]