Hello Guest

Author Topic: Email alert issues  (Read 861 times)

0 Members and 2 Guests are viewing this topic.

Offline racocella

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Email alert issues
« on: August 16, 2016, 03:44:33 PM »
I have been working on and off on installing Pandora FMS 6.0 using the appliance CD and trying to install from scratch, I about to give up and look for something else. The thing that keeps me coming back is that I see value in once it is set up, being able to monitor my organizations servers', network equipment, etc...

   I need some help! I have been trying to get the Alert emails to work and the more that I find on Google about installing this program, the more frustrated and confused I get. My organization has moved to Office 365 and it has been a real pain to figure this email out. I ended up setting up a gmail account and configuring SSMTP and now Postfix. I can send test emails from the Centos server to the email account that I have set up in Office 365, the account is a shared mailbox and will forward emails to the IT technicians. Currently, I am getting chron emails every hour to my shared mailbox, so, I know that part is correct. I can not get the alerts to "fire" to that same email address, no matter how I configure it.

   Can someone tell me what is a configuration that they are using with either gmail or Office 365? I want to get moving on configuring the program to monitor my equipment, not "chase my tail" in just trying to get alerts to work. I would appreciate any help with actual file layout as I know know that my config is wrong and publicizing it wont help. Thanks for any help!

Offline enrique_m

  • Administrator
  • Sr. Member
  • *****
  • Posts: 137
  • Karma: 3
    • View Profile
Re: Email alert issues
« Reply #1 on: August 18, 2016, 12:20:15 AM »
Hi racocella.

In your Pandora server all you need to configure are these tokens:

Code: [Select]
mta_address <mail_server>
mta_port <port_number>
mta_user <mail_user>
mta_pass <user_password>
mta_auth [LOGIN | PLAIN | CRAM-MD5 | DIGEST-MD]
mta_from <mail_adress>
mta_in_separate [1 | 0]

You only need to fill the above tokens and Pandora server will use this configuration to send emails. I let you here the section of the wiki where it's explained.

Hope this can help you.

Kind regards,
Enrique.

Offline racocella

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: Email alert issues
« Reply #2 on: August 24, 2016, 01:16:54 PM »
The answer provided does not help me. I have tried this suggestion in the following ways:
   mta_address <mailserver> : localhost; IP Address of Server; IP Address of Organization's mail server; smtp.gmail.com
   mta_port <port_number> : tried 25 and 587 with each of the above choices
   mta_user <mail_user> : tried local org. email account; tried gmail account with each of the above
   mta_pass <user_password> used associated password with each of the above accounts
   mta_auth [LOGIN | PLAIN | CRAM-MD5 | DIGEST-MD]: used with each of the above choices
   mta_from <mail_address>: used local org's email; used pandora@....
   mta_in_separate [1 | 0]: used the 1, for separate emails

    As you can see, I went through a lot of iterations trying to get this to work. This is the last thing that I need to get working in order to get this fully monitoring my network. The alerts are not going from Pandora FMS 6 to postfix and then out to gmail or my organizations email account. Yet, the chron hourly emails are being delivered on the hour.
    I would really like to get this working!

Offline enrique_m

  • Administrator
  • Sr. Member
  • *****
  • Posts: 137
  • Karma: 3
    • View Profile
Re: Email alert issues
« Reply #3 on: August 25, 2016, 12:33:01 AM »
Hi racocella,

I recommend you to set "verbosity 10" in your "pandora_server.conf" file and try to force an email alert. In your file "/var/log/pandora/pandora_server.log" should be some lines referring the alert execution. If you find something like this:

2016-08-25 08:37:55 localhost.localdomain [V1] [ERROR] Sending email to test@test.test with subject Test

Maybe the error is in your destination address in the alert action. Of course, this error can be caused due to a bad configuration in your Pandora server (what is more likely).

You can check your postfix logs "/var/log/maillog" and "/var/log/mail.err" (if exists) too and try to get more information.

Kind regards,
Enrique.

Offline ayad99

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: Email alert issues
« Reply #4 on: January 15, 2017, 08:46:18 AM »
Hi racocella

Are you still facing this issue? We also faced this issue and we were able to resolve it. Did you know that there is a built-in MTA (mail server) within the PandoraFMS (if installed by ISO appliance). So in that case you don't need to use any external MTA and hence no need to configure the external MTA settings in the "pandora_server.conf" file. Make sure that you use a legit "from/sender" address so that your mailbox doesn't classify that as spam emails and reject it.

Are you following this and does it help?

Regards