Hello Guest

Author Topic: Tentacle service fail  (Read 2507 times)

0 Members and 1 Guest are viewing this topic.

Offline iluizio

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
Tentacle service fail
« on: September 18, 2012, 07:57:12 AM »
All,

I installed the Pandora FMS server (version 4.0.1) in a Open Suse version 11.4 machine and I can not to start the Tentacle service with a command "service tentacle_serverd start". The error message is:

Sorry, user root is not allowed to execute '/usr/bin/tentacle_server -a 0.0.0.0 -p 41121 -s /var/spool/pandora/data_in -i.*\.conf:conf;.*\.md5:md5;.*\.zip:collections -d' as pandora on brtsvisp073.
Tentacle Server could not be started.
Verify that port 41121 is not used.

Thanks,

Offline Nacho

  • Smart member
  • *****
  • Posts: 250
  • Karma: 0
    • View Profile
Re: Tentacle service fail
« Reply #1 on: September 20, 2012, 02:36:25 AM »
Hi;

Could you attach the result of executing the command

ls -l  | grep tentacle

inside /usr/bin



(Otherwise you can try /etc/init.d/tentacle_serverd)

Regards



Offline ronybigsoc

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
    • View Profile
Re: Tentacle service fail
« Reply #2 on: January 18, 2017, 08:34:34 PM »
Any word on this?

I tried to run the command it is doesn't return anything.
Thanks in Advance,

- rony

Offline ronybigsoc

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
    • View Profile
Re: Tentacle service fail
« Reply #3 on: January 18, 2017, 08:50:41 PM »
I am correcting myself. Here is the results after i changed to the correct directory.


xxxxx@Pandora-Server:/usr/bin$ ls -l | grep tentacle
-rwxr-xr-x 1 root   root      22343 Nov  4 03:14 tentacle_client
-rwxr-xr-x 1 root   root      38242 Nov  4 03:14 tentacle_server
Thanks in Advance,

- rony

Offline antonio.s

  • Administrator
  • Smart member
  • *****
  • Posts: 288
  • Karma: 2
    • View Profile
Re: Tentacle service fail
« Reply #4 on: January 19, 2017, 12:56:48 AM »
Hello ronybigsoc,

Try executing:

Code: [Select]
/etc/init.d/tentacle_serverd start
If it still doesn't work, you may need to run it as a different user (pandora or tentacle would work).

Kind regards,
Antonio.

Offline luigli

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: Tentacle service fail
« Reply #5 on: January 19, 2017, 11:28:20 PM »
I had the same problem.
My solution was edit file
Code: [Select]
/etc/init.d/tentacle_serverd and remove option [-v] in TENTACLE_OPTS (about line 90)
-- original --
TENTACLE_OPTS="-a $TENTACLE_ADDR -p $TENTACLE_PORT -s $PANDORA_SERVER_PATH $TENTACLE_EXT_OPTS -d -l $TENTACLE_LOG_FILE -v"

-- change to --
TENTACLE_OPTS="-a $TENTACLE_ADDR -p $TENTACLE_PORT -s $PANDORA_SERVER_PATH $TENTACLE_EXT_OPTS -d -l $TENTACLE_LOG_FILE"

When running in daemon mode, it seems that tentacle server doesn't admin verbose option

Offline antonio.s

  • Administrator
  • Smart member
  • *****
  • Posts: 288
  • Karma: 2
    • View Profile
Re: Tentacle service fail
« Reply #6 on: January 20, 2017, 05:48:32 AM »
luigli,

That parameter shouldn't interfere anyway, but maybe you've found some kind on incompatibility. Are you using also Suse linux?

Kind regards,
Antonio.

Offline ph

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: Tentacle service fail
« Reply #7 on: January 20, 2017, 08:55:39 AM »
It breaks, because it tries to create a log file /var/log/pandora/tentacle_server.log as a pandora user.

You can do this as a workaround:
Code: [Select]
touch /var/log/pandora/tentacle_server.log
chown pandora:pandora /var/log/pandora/tentacle_server.log

Offline luigli

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: Tentacle service fail
« Reply #8 on: January 24, 2017, 12:56:34 AM »
I use Ubuntu 12.04 LTS
I applied solution posted by ph and it worked for me. So now i can use param -v to log to
Code: [Select]
/var/log/pandora/tentacle_server.log