Hello Guest

Author Topic: "There was an error creating the group"  (Read 95 times)

0 Members and 1 Guest are viewing this topic.

Offline breadcrumb

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
"There was an error creating the group"
« on: February 22, 2017, 06:01:46 AM »
Hi,

Since the release of 6.x I have been unable to create additional agent groups using the web console interface - I have had to manually go and create the groups using sql. Currently I have experienced the same problem with 6 SP5.

Everything I do is as per the documentation and once the form is submitted the response I get is "ERROR  There was a problem creating the group.

The apache log simply shows that it accessed "http://localhost/pandora_console/index.php?sec=gagente&sec2=godmode/groups/configure_group&pure=0" . There are no errors produced within the logfiles.



Offline antonio.s

  • Administrator
  • Smart member
  • *****
  • Posts: 278
  • Karma: 2
    • View Profile
Re: "There was an error creating the group"
« Reply #1 on: February 23, 2017, 01:49:31 AM »
Hello breadcrumb,

Could you also check the pandora logfile? By default: /var/www/html/pandora_console/pandora_console.log

Kind regards,
Antonio.

Offline breadcrumb

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: "There was an error creating the group"
« Reply #2 on: February 24, 2017, 06:24:23 AM »
Hi Antonio, thanks.

I tried again while monitoring the console log as suggested. Still fails and I'm getting the following error pop  up:

PHP Warning:   Creating default object from empty value in /srv/www/htdocs/pandora_console/godmode/groups/group_list.php on line 304

Line 304 in that php code is working on the table object:

301:  db_clean_cache();
302:  $groups = users_get_groups_tree ($config['id_user'], "AR", true);
303:
304:  $table->width = '100%';

As far as I can see thats when it has already tried to create the group and moved on to displaying the table again.


Offline antonio.s

  • Administrator
  • Smart member
  • *****
  • Posts: 278
  • Karma: 2
    • View Profile
Re: "There was an error creating the group"
« Reply #3 on: February 27, 2017, 12:51:56 AM »
Hello breadcrumb,

What's the user permissions your user has? Have you tried creating the groups with the global admin user? It looks like it may be something related to permissions.

Kind regards,
Antonio.