Hello Guest

Author Topic: Dependency error when upgrading to sp5  (Read 84 times)

0 Members and 1 Guest are viewing this topic.

Offline fritzvogler

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
    • View Profile
Dependency error when upgrading to sp5
« on: February 07, 2017, 01:37:14 AM »
When I try to update the SP5 agent using
 
Rpm -U --force pandorafms_agent_unix-6.0SP5-1.noarch

I get

"Error: Dependency Error:
Perl (IO :: Socket :: SSL) is required for pandorafms_agent_unix-6.0SP5-1.noarch "

Some help?

Offline antonio.s

  • Administrator
  • Smart member
  • *****
  • Posts: 288
  • Karma: 2
    • View Profile
Re: Dependency error when upgrading to sp5
« Reply #1 on: February 07, 2017, 05:13:18 AM »
Hello fritzvogler,

You will need to install the perl dependency, take a look at this repository:

https://www.rpmfind.net/linux/rpm2html/search.php?query=perl-IO-Socket-SSL

You can also install cpan and do it through the cpan interface:

http://www.linuxquestions.org/questions/slackware-14/installing-perl-module-io-socket-ssl-630247/

Kind regards,
Antonio.